For some reason Dolby access screws up my headset, any idea?

Sep 30, 2022
Visit site
Headset: Astro A50's...

So basically the other day i was playing overwatch, suddenly sound stopped working in headset but mic was working, game didn't crash. No issues with PC, GPU was 66c at 100 percent load. CPU 55 to 65c. AIO coolant 29/31c. So temps were fine.

Noticed my youtube videos stopped playing, like buffering and if i clicked play, would instantly pause, but when swapped over to the monitor speakers. Videos started playing again along with the audio. Swapped back to my Astro a50's and again no audio or videos moving. put headset in tray to reconnect, still no audio. So turned headset off and on and restart overwatch. Everything went back to normal. Thought it was a weird glitch, maybe a one off.

But today happened again when playing fifa, but i discovered it was happening when i enable dolby acceess/atmos app, only recenttly installed this. So sometimes it would work, but then maybe after 10minutes, maybe after 2 hours, who knows. Disabled everything and then working fine, 3 hours later windows automatically enabled windows sonic for headphones, and same issue happened again, i turned that off and everything wen't fine again. Why is the spatial sounds feature messing with my Astro A50's, doesn't affect pc speakers. Pc screwed?, headset screwed? or just some compatibility issue? Also when it happened, i have to manually re-select discord to headset again, to make it work in discord.
The three things I would check first are your audio drivers, your bluetooth drivers and, unfortunately, the X Box Game Bar.

Your headset itself may or may not need drivers. Normally headsets don't, but yours has a dongle or something that you plug into the PC through a USB port, and I'm not sure whether there's a driver for that or not.

As far as the X Box Game Bar, we've only had one wireless headset in my house, and whenever we tried to use it, it didn't work properly, and we found out that sometimes the audio settings in the Game Bar weren't correct. We weren't even using anything Xbox related.

Anyway, do some experimenting. If you normally connect through bluetooth, try connecting via cable to your audio-out jack and see if that changes anything.

I doubt there's anything wrong with either your headset or your PC. This sounds like software screwing up. Hopefully updating drivers will fix that.
  • Like
Reactions: Brian Boru
Normally headsets don't, but yours has a dongle or something that you plug into the PC through a USB port, and I'm not sure whether there's a driver for that or not
The couple of Logitechs I've had with USB dongle: I'm fairly sure they didn't need a driver—but by no means certain—but what they definitely needed was a "pairing" operation by the user. May not be relevant here tho, since as far as I know headset wouldn't work at all without doing the pairing job.

Couple of links with the basic approach:

  • Like
Reactions: ZedClampet
Hard to say, My first response would be to uninstall all sounddrivers compleetly and then reinstall them, after that reinstall Atmos again. But you could start by uninstalling atmos and install it again and see if that helps.
  • Like
Reactions: Brian Boru


Latest posts