Question I have a constant dip in frames that causes lag

Jun 22, 2023
Visit site
I have a Razer Blade with an RTX 3070, 16 GB of RAM, an i7 Intel CPU, and a 1 tb SSD. When I run Apex Legends on it I average 110 frames per second.

My issue is that no matter how many graphic settings I turn off, or how low I cap my frames, I always suffer an fps dip of 6-10 frames or lag that lasts for a millisecond and repeats roughly every 5 seconds. This causes a choppy gaming experience and in general, when I'm browsing on my computer I suffer the same chops.

I have tried every anti-aliasing feature in the game and each one doesn't change the situation. I've tried updating my graphics driver from Nvidia driver 471.68 to the newest 536.23 which only made matters significantly worse, to the point where my computer could only put out 30 frames on my desktop, so I downgraded back to 471.68.

Does anyone have any suggestions as to what might solve this? Maybe there are some settings I can try out, or maybe there's another driver version that might better fit my needs. I'm open to any suggestions.
Hi, has this always happened or did it work OK for some time and then start to do this? How long have you had the laptop?

I have a couple of suggestions anyway.

Monitor your temperatures and CPU frequencies using something like Hwinfo, if temperatures are hitting a limit and its thottling to prevent overheating it could cause something like this. Solution for that is to clean all the vents out with an air duster of some sort, or even better open it up and clean it out properly. Better check your warranty conditions on that one first though, if youre not comfortable get someone in a pro shop to do it or speak to Razer support if its in warranty.

If its not overheating, could be a driver or software issue somewhere else. Close down any third party software that's running in the back ground while you're playing. That includes any Razer software they pre installed on the system to control RGB, 'game optimizers' or whatever they have these days.

Remove any USB peripherals you can like, external drives, speakers or headphones and test again.

Try those, or tell us if you did already :)
  • Like
Reactions: Brian Boru


Latest posts