Turning off email notifications

I've gone into the preferences and turned off all of the checkboxes that mention emails or email notifications. But I still get a ton of emails every time someone replies to me. The only thing that's left is just to uncheck the normal box for getting notifications for replies, but I would have thought that would be talking about the bell icon notifications, and not emails. I'm afraid if I uncheck that, I won't get any notifications at all when people reply to me. Does anyone have any ideas about how I can truly stop getting emails?
 
How many did you get for this reply?

Just curious re why you'd get more than one—I don't get any, so I'm not familiar with the niceties of the email system here.
I got one email for your reply. I guess I wasn't clear. I only get one email per reply, but I've gotten a bunch of replies, so I get a bunch of emails. For some reason, I can't figure out how to turn off email notifications. All of the boxes are unchecked. I guess I'm going to have to turn off all notifications, even the ones on the site. It's definitely not working like it should be, though.

Edit: I just turned off all alerts, so we'll see what happens...
 

Zloth

Community Contributor
For some reason, I can't figure out how to turn off email notifications. All of the boxes are unchecked.
There's two under "email options" and there's two more under "content options". I've got those 4 turned off and I don't think I get any emails. Be sure to hit the Save button at the bottom. (This message can double as a test!)
 
There's two under "email options" and there's two more under "content options". I've got those 4 turned off and I don't think I get any emails. Be sure to hit the Save button at the bottom. (This message can double as a test!)
I actually still got an email after turning everything off, but it wasn't for a reply. It was for somebody being added to a group, or something. I don't get it. I have every single thing turned off that has to do with any emails or alerts.
 
I have never received an email from here, but then the last email I got from any Future forum was Feb 2019 apart from when I had to swap mobile phones and reset my logon info to match. Feb 2019 was coincidentally when we started using Xenforo (the forum software).
So I am not right person to answer this lol.
 
I got another email today for someone replying to a watched thread. At the bottom of the email, it gave me the option to stop receiving all emails. So I clicked that. Hopefully that takes care of it. We'll see...
 
Nov 4, 2020
169
323
970
Hi wooden , i dont think you are doing anything wrong i personal think the email software this site uses has a few bugs in ..... just saying !

I get a lot of auto response emails from this forum and i think 75% of them are from threads that i have not even taken part in.
 

CParsons

Staff member
Dec 9, 2019
255
659
2,770
Make sure you shut off anything you're already watching:


Anything set up as 'Watched' before you changed settings won't be retroactive. They need to be manually removed or email notifications disabled. This is so you can still choose to watch a Thread / Forum, without it being an all or nothing scenario.
Yeah, that was probably my whole problem. I think it was probably set up to automatically watch any thread I posted in. It seems like when I clicked in an email to stop receiving all emails, that took care of it for me. But I do think you were right on about this. Thank you!
 
  • Like
Reactions: SWard and CParsons

ASK THE COMMUNITY

TRENDING THREADS