Formatting issue

OsaX Nymloth

Community Contributor
Jan 29, 2020
120
154
270
nerdomancer.pl
So I noticed this thing going on and it's kinda annoying when trying to format a whole lotta text, like the one on Icewind Dale recently.

The issue: trying to apply formatting like bold, italic etc. on selected line does it - but it also applies the formatting to everything after selected line. For example if I were to select a header and try tinkering with it, all the effects I apply to it will also apply to every paragraph below.

Windows 7, latest Firefox. Not sure if this behaviour exist in Chrome or is it specific to FF.
 

MaddMann

A nerd that found his place
Community Contributor
Jan 17, 2020
98
115
220
I am rather confused what you mean by this. What does Icewind Dale have to do with it? Is this an issue with html formatting here on the forums? Are using a specific program?
 

OsaX Nymloth

Community Contributor
Jan 29, 2020
120
154
270
nerdomancer.pl
@MaddMann Icewind Dale was just an example of long post I made that required some formatting - and since formatting seems to be problematic, it made me post about the issue here.

Example short video (mp4 on imgur) of the problem. Notice how I am trying to add BOLD only to the HEADER and it's applied to everything after it.



 
  • Like
Reactions: I Will Haunt You
@MaddMann Icewind Dale was just an example of long post I made that required some formatting - and since formatting seems to be problematic, it made me post about the issue here.

Example short video (mp4 on imgur) of the problem. Notice how I am trying to add BOLD only to the HEADER and it's applied to everything after it.

I have that happen as well. Sometimes you apply it to just one word and the entire body becomes affected.
 
Last edited:

OsaX Nymloth

Community Contributor
Jan 29, 2020
120
154
270
nerdomancer.pl
@MaddMann wrote that in OP, Firefox under Win 7. No add-ons that should interfere with WYSIWYG stuff.
I don't have such problem in other online editors, like Wordpress etc. only here.
Never used this forum software before, so it may be something with the "engine" forum uses.
 

Colif

Moderator
Jan 2, 2020
89
85
120
It appears its a known issue with the forum software starting last year, only on Firefox


known by Xenforo, perhaps not known by Admin here :)
 
Jan 22, 2020
112
161
270
I've found some of those text formatting buttons a little hinky too, particularly with image linking, so I've just been using the BBcodes to alter text or insert images or hyperlinks. Or just to do stupid stuff like this.

There's a list here if which might be helpful if you're interested in giving us any more big posts like your IWD thread.
 

JSimenhoff

Community Manager
Staff member
Nov 25, 2019
62
103
220
I've found some of those text formatting buttons a little hinky too, particularly with image linking, so I've just been using the BBcodes to alter text or insert images or hyperlinks. Or just to do stupid stuff like this.

There's a list here if which might be helpful if you're interested in giving us any more big posts like your IWD thread.
Bbcode is definitely the way to go if you want precise formatting. You can access the bbcode editor by hitting the cog on the right side of the toolbar.

We do have updates to the forum software planned for the future. It will solve many quality of life issues such as this one. Please be patient and we will update you once we have a firm date for rollout.
 
Jan 13, 2020
247
354
670
Actually, I just noticed that you don't seem to have any link to BB code formatting! You can use the toolbar to make some text format then click the gear icon to see what the board did but that doesn't give you all the syntax.

But yeah,
you can certainly make some nice some nice, detailed formatting if you really want!
 
  • Like
Reactions: JSimenhoff

ASK THE COMMUNITY