Ethernet Adapter Not Showing Up On Device Manager

Aug 14, 2021
Visit site
So I just recently built a pc, and today managed to install windows 10 on it. I don’t have a wificard, as I was planning to use Ethernet. Once I got windows downloaded and ready, I plugged the Ethernet cord from my LAN port to my wall, and it didn’t work. I ran the network Troubleshooting, and it said it could not find a driver for my network adapter. I thought that was strange, so I went to Device Manager, and went to update the drivers for my adapter, but it didn’t appear under Network Adapters. I don’t think it is my motherboard as it is brand new and the lights near the LAN port light up like it works. I’ve also tried things like showing hidden devices and restarting my bios, but nothing seems to work.

I am stressing out of my mind trying to fix this and I would love to get a response. Thank you in advance :)

Motherboard: AsRock B560 Pro4
Aug 13, 2021
Visit site
u can see network chip at board, see the name on chip, it will help u to find a good driver. just like this. u take code number and search that driver..
Last edited:
Have you tried downloading the LAN driver for your motherboard on the asrock website?:

Once downloaded, if you unzip and run the driver update again, it might work.

Edit: You will need another PC to download it to then put it on a USB stick though.
Last edited:
  • Like
Reactions: Brian Boru