Please help with running total war three kingdoms ultra unit size.

May 3, 2020
2
0
10
Hello guys, I need your help, I am playing the game total war three kingdoms, my CPU is an AMD Ryzen 2600x, my gpu a GTX 1060 FTW 6GB, 16 GB OF RAM. and well I have a problem when I run my game on ultra unit size, When in normal speed my units look fine, but when I fast forward you can see there is a slight lag when troops move, they look a bit laggy, when on large unit size it looks perfect, but then I see to few units and I am like meh lol. I run the game on medium high, like Textures high, unit textures high or med, and the rest is pretty much medium or high. So my question is, is my pc to weak to run the ultra unit size? or is there a way or a specific way to tweak my graphics so it can run smoothly when I fast forward my units?
My fps never drop below 60 fps, like even when I see my units lag the fps were about 65 lol.

What is the normal or the best fps for this game? oh and btw im playing on a 1080p monitor.
Thank you very much for your help, and well please any advices are well taken.
 
May 2, 2020
13
14
15
I've had the same experience in every Total War game with this. Fast forwarding is essentially asking your system to hurry the heck up and process all of the information in 1/2 or 1/4 of the time. Try lowering all of your settings while keeping the ultra unit sizes and see if it still happens.
 
  • Like
Reactions: Zoid and Gray_fox46

Zoid

Community Contributor
Jan 13, 2020
545
739
5,770
Unit stuttering is something of a known issue, and isn't really an indication of your hardware being "too weak" for ultra unit sizes, and as you say you never drop below 60fps. The stuttering is due to some weirdness within the game and is present in other TW titles as well. Here are a few things you can try:

As @lamboto suggests, you can try lowering all of your other graphics settings besides ultra unit size to see if it solves the stuttering.

Try switching to slow motion when you see the stuttering and see if it goes away.

Try locking your framerate to 60 (or even lower) to see whether that reduces the stuttering.
 

TRENDING THREADS

Latest posts