Newly Upgraded PC Turns on but wont boot up

Nov 28, 2020
1
0
10
Hi all, I recently upgraded my PC and have spent the last eight hours trying to get this thing to work. When I turn it on, all the fans start spinning, but no signal is sent to my monitor.
Ive tried taking out a single ram stick, on both ports, putting in my old ram stick, tried booting it up without it connected to hard drives, tried having my monitor only connected to the GPU, i saw some guy on youtube describe my very problem and it being with the power supply so I drove an hour to BestBuy and got a new power supply. And the same problem consists... Does anyone know what the possible problem could be?
Hardware:

Any help would be much appreciated!
 
Oct 8, 2020
26
54
620
A quick search on the ASRock site reveals the RAM isn't on the QVL: https://www.asrock.com/mb/AMD/B450M-HDV R4.0/#MemoryPR

(This was a quick search though. so perhaps do a thorough search to be sure).

Also, I think about 95 out of a 100 times a non-qvl RAM works fine. Sometimes you just get the... wrong end of the RAM-stick :cool:

I had the same thing a little over a year ago with my ASRock B450M Pro4: I bought Crucial Ballistix Sport LT Ballistix RAM sticks which turned out to be the problem (they weren't on the QVL; at the time, I had no idea what QVL was). My system was stuck in a bootloop and didn't go past POST.

First I tried a new PSU too, but no joy. After that I sent back the RAM and got sticks which were on the QVL and it worked like a charm.

My money would be on the RAM. But perhaps it could also be a GPU which was dead on arrival? Or maybe the motherboard?

If possible, check if the GPU works on a friends system. Or another GPU on your system.
 
  • Like
Reactions: Kaamos_Llama

ASK THE COMMUNITY