New HDD not responsive, dead? Help

Jun 19, 2021
12
43
50
Visit site
Hi Guys

I wanted your help, I just finished building my new rig, I booted it, and everything works like a charm except the HDD which is not showing up (but does appear in BIOS, devices and is recognized my several HDD related programs)

I tried the usual of initialing it with Windows Disk Manager, but I get the i/o error, also using other tools like Partition Wizard among others they can see the brand, model, capacity and that it has not been initialized but every attempt to do it or format it fails (usually get non descriptive errors or I don’t get the option to do X o Y)

Using WD HDD dashboard it can’t be formatted (gets simple error) and it mentions that is “locked”

Tried changing SATA cables, power cable and even plugging it to a different SATA port but no dice

Any recommendation on something else to try? I’ve had dead HDD before and usually I don’t get as much info from the PC regarding the HDD “existing” or it doesn’t spin/strange noises, this one (a WD Black 8TB) at a simple externa glance “works”

Appreciate all the help!