Feature PCG's Virtual Halloween Party: Share your PC Building Horror Stories!

Page 2 - Love gaming? Join the PC Gamer community to share that passion with gamers all around the world!
Mar 30, 2020
17
10
515
Not so much of a horror story but just a huge issue for me.

I recently built my first desktop in almost a decade and made some much needed upgrades. I did a completely fresh build and went full AMD. Got a RX 5700XT GPU and a Ryzen 7 3700x CPU. Everything got installed just fine but for about 3 months i fought some bad issues. Between intermittent lag when gaming on League of Legends, and frequent crashes (especially when attempting to stream), i knew something was wrong. I tried everything from fresh installs, to reseating GPU, stress tests (all passed with flying colors), and much more. Nothing seemed to work. My monitor (144hz), would also not display anything above 60hz. This was a nightmare and i hated it. The solution ended up being deleting a program that i had NO idea was installed or how it even got there. Apparently some Nvidia software found its way onto my PC and was just messing everything up. Deleting this fixed everything and my pc is now amazing and i love it. :D
 
Feb 6, 2020
10
2
515
Only ever had one really bad one. This happened back in 2011. It was not my first build, I'd been putting together my own systems since around 2000. I had decided to upgrade to an AMD990FX board and also upgraded to DDR3 RAM as my current system was running first gen DDR RAM, but keeping the existing processor.

Everything went together with no issues. However it wouldn't post. So after going through all the normal troubleshooting steps, I found that a couple of the pins on the CPU were bent. I very carefully straightened them and tried again. The CPU didn't want to go in and despite not pushing on it at all, more bent pins. This time when straightening, ping, pin broke off. Dead CPU.

So I dug out an four year old CPU from a previous build from my parts drawer. Was EXTREMELY careful in attempting to put it in the new board. Still wouldn't go in. On inspection the pins on this one were trying to bend. So checked the CPU socket and it appeared a couple of the holes in the socket had a bit of plastic flash in them still. So RMA'd the board and ordered a new Phenom II processor to replace my dead one.

Once the new board arrived, it installed into the system fine. I decided to be extra paranoid and tried to install the old processor first. Good thing too as it managed to snap a pin off that one as well. Again with no pressure on the CPU when installing.

I was determined to get it running, and after inspecting the socket for a second time for obstructions I tried with the brand new CPU. I lined up the pins as best I could and just let it sit on the socket. Ended up tapping the side of the socket a few times to jog it a bit and the CPU finally dropped in. Everything worked from there.

My theory is it was an issue with the AM3+ sockets having slightly larger holes to allow for the larger pins on the Bulldozer chips. This allowed for the pins on the older chips to be slightly out of alignment and snagging. Never had a problem like it before or since. And those two remain the only CPUs I've ever damaged.
 
  • Like
Reactions: SWard

ASK THE COMMUNITY

Latest posts