Question PC will post outside of Nzxt H510 case on motherboard box, but not when all parts are installed

Status
Not open for further replies.
Aug 15, 2022
2
2
15
I have taken apart and put back totgether my PC so many times now from trying to find out why my pc won’t post, that I think I can put a whole PC together in under 20 min…. After I have gone through every troubleshooting process possible I ended up building the PC outside of the case, and what do you know it works, and after that I plugged in the Sata cable and it has everything there. But every single time I try to put it together in my case the fans will spin no motherboard light and the pc won’t post. Also I know there isn’t anything wrong with any piece of hardware because I put my old motherboard back into my pc and everything works. So to summarize both old and current motherboards work, but the new one will not post when assembled in my case.
 
Last edited:

COLGeek

Moderator
Jun 7, 2021
653
1,057
2,770
Sounds like a grounding issue. Double check for any extra stand-offs/mounting points under the motherboard. Also, check the little fingers around the various motherboard ports to ensure none are bent and sticking into the ports themselves.
 
May 22, 2022
223
327
670
That's just weird, I never ran into an issue like this, but hey, assembling PCs are very touchy sometimes. 😅

assembling hardware together sometimes turn out like programming software, they just don't work together sometimes.
 
  • Like
Reactions: Brian Boru
Aug 15, 2022
2
2
15
Sounds like a grounding issue. Double check for any extra stand-offs/mounting points under the motherboard. Also, check the little fingers around the various motherboard ports to ensure none are bent and sticking into the ports themselves.
If I could I would kiss you right now. After I read your comment I went back and took the motherboard out of the case and what I ended up finding was a standoff with no screw hole that was going through one of the holes on the motherboard after I took that out and put one with a screw hole in, everything worked just fine 😭😭. I’ve literally been troubleshooting my PC for a whole month and a half….. thank you so much for telling me to check just one more time I couldn’t be more grateful. 🙌🙏🙏
 
  • Like
  • Love
Reactions: Alm and Brian Boru

COLGeek

Moderator
Jun 7, 2021
653
1,057
2,770
If I could I would kiss you right now. After I read your comment I went back and took the motherboard out of the case and what I ended up finding was a standoff with no screw hole that was going through one of the holes on the motherboard after I took that out and put one with a screw hole in, everything worked just fine 😭😭. I’ve literally been troubleshooting my PC for a whole month and a half….. thank you so much for telling me to check just one more time I couldn’t be more grateful. 🙌🙏🙏
Glad you got it sorted out. Have fun!
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS