New PC not booting; DDR5 6000 kit

Jan 13, 2023
Visit site
hey everyone,

I got me some new hardware, build a nice new PC, I'm in seventh havean and than I press the power button... get nothing on the display.
So I can't go into the BIOS and can't boot the USB to install Windows 11.

My best guess is the DDR5 RAM, because my understanding is that I have to activate XMP on the mainboard, but I have to get to the BIOS first.
Second guess is that the display with the Displayport is not working.

My System:
GigaByte Z690 Aorus Pro
Seasonic Prime TX TX-750W
Intel Core i5-13600K
be quiet! Dark Rock 4 Pro
G.Skill Trident Z5 32GB Kit DDR5-6000
RTX 4070 Ti
be quiet! PURE BASE 500DX

What happens when I press the power button?
The system is getting startet, fans are going, mainboard is cycling through the boot sequence. Than there are some error numbers on the motherboard: 54 (Memory initialization error occured), 59 (CPU micro-code is not found or update failed), also C2, C4 at the end C1 ( all named as "reserved" in the manuel).

I hooked in the displyport display directly to the motherboard, also tried it directly to the graphics card. Eventually I tried plugin in the tv with HDMI to the graphics card... still nothing.

The system looks correctly wired, have both ATX power connectors connected for the CPU.

update: I followed toms gardware checklist, and removed one of the two RAM units, leaving just one in the A2 slot. Now the system is not rebooting, I get no fancy error numbers, just a 12 (reserved, in normal boot up). But still I get no output on any display, not via graphics card nor integrated CPU / GPU UNit on the motherboard...

Has anybody an idea why the system is not displaying BIOS? Any components not compatible with each other?

best regards and help very much appreciated,
Last edited:
  • Like
Reactions: Brian Boru