Question My SSD is preventing my PC from booting & getting to Bios

May 6, 2021
Visit site
I turned my pc off after watching some Netflix or something, it wasn't mid update or anything like that, but now it won't boot or even let me into the bios. I tried using a recovery usb and it made no difference. It gets stuck at the MB splash screen and it seems that my ssd is the issue because when I take it out it let's me go to bios or even run linux. What makes it worse is I have no idea what brand ssd it is and I can't check because the ebay account I bought it from was deleted ages ago.

Things I've already tried: Q-flash button on motherboard, clear cmos, removing cmos battery, reseating ram, reinstalling ssd, checking and reseating all power connectors, installing linux, attempting recovery mode with power button, cold boots, hot boots, hot swapping.

Ryzen 7 3700X @ 4.2Ghz
16GBs Klevv Ram @4000mhz
RTX 3070
Integrator 750w modular power supply.
Gigabyte B550 M S2H motherboard
(Unknown brand) M.2 SSD 1TB

Video of it happening
  • Like
Reactions: Brian Boru
Apr 1, 2021
Visit site
i had a very similar problem with my ssd. it kept reverting my HHD as priority. after weeks of hunting round online i came across a post (forget where) who had the same issue and the problem was the ssd firmware needed updating, updated it and had no more of that sh@t happen again. i know you dont know the brand etc but that would be my guess.
Good job with your post & video—nice and clear, and I admire your restraint :)

If your PC is pre-built, go to the maker's site & look for SSD firmware update there.

If PC self-built:
Press Windows key
Type System Information
Click on System Information app in pop-up
Click the + beside 'Components'
Click on + beside 'Storage'.

Find your SSD listing—"Size" is likely your best guide—and check the Manufacturer and Model entries. If Mfg not specified, searching for the Model should find the Mfg, and you can grab their firmware update.

Of course, this would work for pre-built PC too.