Wolfenstein 2 — It just won't play now - #str_online_connection_error_03 + Video driver has run out of dedicated memory? + Save Games?


I can't even load the game anymore.... I can open the game, go to the menu's, but it won't load the saves etc.

Now I'm getting #str_online_connection_error_03

This period of problems started over the last week - completely out of no where.......
Started with the bizarre Video driver has run out of dedicated memory .
Which makes absolutely no sense considering my system specs.

Most the time it wouldn't really do anything - but sometimes it'd crash.

But now - I can't play at all... because of the new #str_online_connection_error_03.

If I try to select Continue from the last autosave - it does this error.... and if I try to open another save file, it either does the same thing or just straight up jams until I close it from the Task manager?

In the game - I'm in the middle/end of the Roswell levels.... I've heard other people say they had the same problems in exactly the same spot?

Tried updating Nvidia drivers, no change, I've already got the latest windows updates etc etc...

This is via Xbox Game Pass for PC if that matters....

Found loads of other people with exactly the same nonsensical error - but no fix?

BTW - how do you backup save games for this game and other Xbox Game Pass for PC games?

Thank you for your help

[Mod edit: changed forum & changed title for clarity from "Video driver has run out of dedicated memory?".]
Last edited:
my system specs
You should probably start with those, so people can have some clue what you're dealing with.

Generic Guide:

Of particular interest are:
Exact make & model of your Power Supply;
Case & cooling parts;

Graphics card;
Monitor model & Hz;
Resolution you're running at;
What graphic settings level have you enabled?

Are all drivers & BIOS up to date?

Have you tried the simple step of uninstalling and reinstalling the game?
Video driver has run out of dedicated memory
this is a bug that was introduced with a patch
There is a post pinned on the first page of discussion, this is a known issue with latest patch. Two things can help;

- Close Origin. Several people found that if Origin is running on your PC, even as a background task, contributes to this problem. CTRL+ALT+Delete and kill all Origin processes.

- pressing "E" before pressing "Enter" makes the "out of memory" message go away on the loading screen and then you can get into the game

I wonder how many games are actually in series, as this isn't the 1st number 2 - https://en.wikipedia.org/wiki/Beyond_Castle_Wolfenstein
  • Like
Reactions: Brian Boru


Latest posts