WD SN850 issues with x570 boards

Dec 14, 2021
3
0
10
I have an asus x570 pro with an inland premium m.2 1tb for boot and some storage. I was just using for sim racing, but hurt foot and now into gaming and drive is full. This board has a 2nd m.2 but that goes to the chipset. Wanted to take advantage of pcie gen4 so was looking and got an amazing deal on 2TB wd sn850 with heatsink. Looked on web and seen nothing but huge issues getting this to work on 570mb. slow speed, not recognized on cold boot. everything horrible stories. I've pretty much figured that the 2nd chipset slot won't give me advantage of 4.0 anyway so probably pick up 970 evo or something. Anyway, I was able to cancel the sn850 order, but I now learning that WD came out with an update that fixed these issues in July. Wondering if anyone who had issues with sn850 tried update and it works now. Probably still could get deal on 850 and use as pcu slot if needed. So has anyone tried this update with an x570 MOBO?
 

COLGeek

Moderator
Jun 7, 2021
540
894
1,770
I would argue that the Samsung is a better SSD in the long run anyway. Otherwise, the WD should work in most cases.

You could also use a "regular" SATA SSD as a storage drive. Performance would still be excellent.
 
Dec 14, 2021
3
0
10
I would argue that the Samsung is a better SSD in the long run anyway. Otherwise, the WD should work in most cases.

You could also use a "regular" SATA SSD as a storage drive. Performance would still be excellent.
Probably just going with samsung, wont notice speeds and they seem to work. Thanks for help.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts