Question Logitech gaming Software GUI (G402) no longer starts up minimized?

Jun 12, 2020
368
697
1,770
The control panel GUI for my G402 mouse always used to startup minimized to taskbar. After uninstalling (completely using Revo Uninstaller to remove leftover bits), and reinstalling, the same problem persists. I even tried making a shortcut of LGS and in it's properties page, set it to Run minimized, still same problem.

Has anyone else had this problem, and if so, did you find a way to fix it, and how?
 
Jun 12, 2020
368
697
1,770
Pretty sure I've never installed G Hub, just LGS. I've never done anything like RGB lighting or profile plugins, so no need for it. Plus I just now did a Search in W10 taskbar for G Hub, and nothing was found on my PC.
 
its new. it won't auto install. It replaces all functions on LGS.
LGS never worked right with my monitor, I had a 4k screen and instead of using windows scaling for size, it used native resolution. I needed a microscope to read LGS.
At least G Hub got that right.
Try downloading G Hub as they aren't updating LGS anymore.
 
Jun 12, 2020
368
697
1,770
Yeah, despite waiting about an hour for a chat response, and refreshing the chat window every time it said offline, I thought I'd get no response. Then I looked in my email and saw a message from one of their support staff with instructions about G Hub. Strange that they never even bothered to notify their customers via a notification in LGS or an email that G Hub was replacing the old software.

Well, I can only hope G Hub works, because I've read bad testimonials about it too.

Thanks man, this may fix my problem. I honestly thought it might have been system file corruption or a recent W10 update I just installed, because SFC found some corrupt files, and this same thing happened at the same time with the Desktop Reminder tool I use. That was fixed by merely uninstalling and reinstalling though, unlike LGS.
 
Jun 12, 2020
368
697
1,770
Well, I uninstalled LGS, and installed G Hub. It was easy enough to set DPI speeds and Default Shift speed, however the only way the Default Shift button will take me back to actual Default DPI speed is while holding down that button. As soon as I release it, it goes back to the non default DPI speed it was at.

So needless to say this is not how it's supposed to work, and I never had this problem with LGS. I also searched through the G Hub setup manual and don't see anything that indicates I did something wrong, nor does there seem to be any troubleshooting section in the manual.

I can see now why I found some negative testimonials on how G Hub works.

I got on Logi's support page to chat about the problem. The Gaming division guy didn't know how to fix the LGS or G Hub problem, and relayed a message to upper tier support that's supposed to get back to me, whenever.
 
Last edited:

ASK THE COMMUNITY

Latest posts