Question Several games suddenly crashing at launch

Not open for further replies.
Jul 9, 2021
Visit site
As of yesterday, the games listed below that used to work perfectly, started crashing on launch.
I tried last night to reinstall the visual C++ redistributables, and everything worked again, all games launched and ran properly.
After turning the pc off last night and on again this morning, I was back to square 1 with the affected games not launchig. Tried reinstalling clean all Visual C++ redistributables as well as .Net Frameworks and checked all windows updates, but to no avail.
Now whatever I do these games won't launch.
What might affect this?
Can anyone help?
Is a clean windows reinstall my only remaining option?

The affected games are:
MS Flight Simulator 2020 (from MicrosoftStore)
Call of Duty Black Ops Cold War and Warzone (from
Sniper Elite 4 (from Steam)
Anno 1800 (from Ubisoft Connect)
Total War Saga Thrones of Britannia (from Steam)
Sid Meier's Civilization VI (from Steam)

As opposed to the above, the following still work just fine:
Hearts of Iron IV (from Steam)
Assetto Corsa (from Steam)
Project Cars 3 (from Steam)
Star Wars Squadrons (from Steam)
Cyberpunk 2077 (from Steam)

My machine is as follows:
Operating System: Windows 10 Pro 64-bit (10.0, Build 19043) (19041.vb_release.191206-1406)
Language: English (Regional Setting: English)
System Manufacturer: ASUS
System Model: System Product Name
BIOS: 3101 (type: UEFI)
Processor: AMD Ryzen 9 5900X 12-Core Processor (24 CPUs), ~3.7GHz
Memory: 65536MB RAM
Available OS Memory: 65450MB RAM
Card name: NVIDIA GeForce RTX 3080
Manufacturer: NVIDIA
Chip type: NVIDIA GeForce RTX 3080
DAC type: Integrated RAMDAC
Device Type: Full Device (POST)
Device Key: Enum\PCI\VEN_10DE&DEV_2206&SUBSYS_38853842&REV_A1
Device Problem Code: No Problem
Driver Problem Code: Unknown
Display Memory: 42803 MB
Dedicated Memory: 10078 MB
Shared Memory: 32725 MB
Current Mode: 5120 x 1440 (32 bit) (120Hz)

Some errors reported:
Windows Error Reporting:
+++ WER0 +++:
Fault bucket 1744268672590393953, type 4
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: SniperElite4_DX12.exe
P3: 598add49
P4: AudioDevProps2.dll
P6: 60b0a9e5
P7: c0000005
P8: 000000000001ba66

+++ WER3 +++:
Fault bucket 1505469020563273446, type 4
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: ModernWarfare.exe
P3: 60db8ec8
P4: ntdll.dll
P5: 10.0.19041.1081
P6: 088bf621
P7: c0000005
P8: 000000000002b757

+++ WER8 +++:
Fault bucket 1879312130623411228, type 5
Event Name: MoAppCrash
Response: Not available
Cab Id: 0

Problem signature:
P1: Microsoft.FlightSimulator_1.17.3.0_x64__8wekyb3d8bbwe
P2: praid:App
P4: 60c0b1e3
P5: AudioDevProps2.dll
P7: 60b0a9e5
P8: c0000005
P9: 000000000001ba66

Update: I went into C: ProgramData> A-Volute> A-Volute.SonicStudio3> Modules > ScheduledModule> x64
Took out file AudioDevProps2.dll and put it on the desktop (as backup) and most games started working again.
MS FS 2020
The 2 Call of Duties
Anno 1800
Sniper Elite 4
now work.

Total War Saga Thrones of Britannia (from Steam)
Sid Meier's Civilization VI (from Steam)
are still crashing to desktop at launch.
Last edited:
Welcome to the forum—good post, thanks for helping us to help you, and nice job getting most of them back and running :)

I recommend you now take a disk image of C: before further action, since you have an improvement. If you have a Restore Point from before the problem, consider rolling back to that.

Then open an elevated Command Prompt and run…
sfc /scannow [note there's a space before the '/'], let it fix anything it finds—this could take an hour or two, but you can work away while it's running… but I wouldn't run anything major like a fullscreen game.

.Net Frameworks have a history of wonky updates for some/many, altho I've never had trouble with them. They got better over the past year or so, but…

Do you recall adding anything to your system—most likely software, like a game—just before the problem started?

Quick search on AudioDevProps2.dll leads me to:
"In April 2020, SteelSeries acquired Nahimic audio software developer, A-Volute."—Wiki
There also seems to be a Nahimic audio driver involved.

If you installed any sound app or drivers just before the problem started, that's my #1 suspect. Uninstall them if you don't need whatever they're offering.
You may also need to uninstall your Realtek driver and reinstall it, if it got messed up in this problem.

General tips on drivers:
1 Don't update them unless you have a specific need;
2 Turn off driver updates via Windows Updates—you don't need a monthly possibility of breaking something;
3 Get drivers from the OEM first, the card assembler second, and MS last.

It's not that MS are bad, but driver makers don't always supply them with the latest version, or they may get conflicting ones from card maker & OEM. It's a tangle to keep out of.
Jul 9, 2021
Visit site
Thanks, so much for the detailed reply!
I ran the SFC scan and I'm looking into the A-Volute thing.
The only update I did was done automatically via windows updates right before the issue started, so I'm guessing you are exactly correct. Apparently, A-Volute is related to realtek sound drivers that are included in my Asus MoBo. I'll try updating directly from ASUS armoury crate.
Meanwhile, following some advise on a JaysTwoCents video, I set my connection settings to metered and avoiding windows updates on metered connections so that it won't do anything unless I want it to.

  • Like
Reactions: Irwan Maulana
windows updates right before the issue started
Then if necessary you should be able to roll your system back to the Restore Point Windows makes before updates.
I set my connection settings to metered
If that's too drastic—in my opinion, it is—I recommend either:
Use the postpone for up to 30 days setting;
Turn off driver updates via Windows Update.

Shout if you need instructions on either :)
  • Like
Reactions: Irwan Maulana
Aug 29, 2021
Visit site
I had the same problem, some games didn't start. I tried different GPU drivers from Nvidia, it seemed to me that it was the fault of the drivers, nothing helped.
The solution to the problem is to uninstall SONIC Studio3, which installs together with the ASUS motherboard drivers.
My hardware is i7-11700k, Asus ROG Z590-E, Gigabyte RTX 3060, WD Black MNVe4 1GB.
I left it, i.e. I did not uninstall SONIC Radar3 and I set the SONOC Suite Companion not to start when the system starts. And now all the games are starting.
  • Like
Reactions: Brian Boru
Not open for further replies.


Latest posts