My pc won't boot because somehow my CPU preventing my GPU to Function

Aug 9, 2022
3
1
15
Hello! This Problem is new to me so I'll make this as short and informative as possible. so first of all here are my current specs:

CPU: Ryzen 5 1400
Mobo: MSI a320m pro-vd/s
GPU: GTX Geforce 680
RAM: Team group elite ddr4 2666mhz (1x8GB)
PSU: Thermaltake litepower 650w

So I bought GTX Geforce 1650 DDR6 and used it. I have a habit of making my pc automatic sleep every 5 mins if I'm AFK. and one day my pc wasn't able to boot. I check the right side of the MOBO and the EZ debug LED VRAM lights up, which indicates that there's a problem on my display which is the GPU. so the 1st thing I did is take a look at it. I notice a wet-glossy substance and I used a tissue to wipe it out. it has greenish in color so I immediately assume it got peed by rats (we have a rat problem since it was raining every day) since my casing is basically old and open for business. so I tried to clean it off and used it again but still no luck. the timespan of using the new GPU was only 3 weeks so it's still on warranty and I bring it to the store, the 1st thing they did is test it on their system which is much older than mine and it works! so I rush to get my current pc and try to fix it there. they check every possible troubleshooting available:

- Update Bios to the latest
- Reset Bios
- Change the same brand new GPU with my mobo and CPU
- change another 320 motherboards (gigabyte a320m-s2h ultra durable) with my CPU
- change PSU (much older than mine)
- trying different socket display
- trying different display cord

All of these lists did not work but as soon they change my CPU with AMD athlon. it WORKS! with my own motherboard, PSU and RAM. and when they change back to my current CPU it doesn't boot or display. Somehow my CPU prevents my GPU to boot or display. its frustrating because I used it for at least 3 weeks and it's brand new. and somehow it will work with the older hardware but not mine somehow my pc only accepts my GTX 680. Does anybody have this problem? Thank you.
 
  • Like
Reactions: redmark_
Aug 9, 2022
3
1
15
well, that sucks. I guess it's time to let it go. I have specs in mind. I was wondering if this is good or if the PSU is good enough.

CPU: Ryzen 7 5800X
Mobo: Asus TUF B550 or MSI B550-A
GPU: Radeon RX 6650 XT
RAM: Team T-Force Delta TUF (2x8GB)
PSU: Cooler Master Gold 650W
Cooler: Cooler Master hyper 212
SSD: WD green 240GB NVME

What do you think? I really would like to hear any suggestions. Thank you :blush:
 
May 22, 2022
223
331
670
welp, if you're CPU is old too, it might be really time to let that go and replace it. 😀

also what are those specs for? @Kick-Yum are you planning on getting a whole new PC instead?
 
Aug 9, 2022
3
1
15
welp, if you're CPU is old too, it might be really time to let that go and replace it. 😀

also what are those specs for? @Kick-Yum are you planning on getting a whole new PC instead?
Yeah, something like that. but I'm still planning on the PSU since I was hoping on getting the power color hellhound rx 6650 xt which the PSU required is 650. i don't know if that's enough
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts