Question desperate for help on custom loop upgrade?

Mar 23, 2023
1
0
10
Visit site
hi, i built a gaming pc a year ago with a basic rog strix b550 mobo. just the cpu was liquid cooled with an enermax aio 360mm. in the last 2 months i decided to upgrade to a full custom loop with EK everything. i also doubled the ram cap and added a sound card... after filling the loop, i am trying to get all the components to turn on (whole system boot); but i am not sure why it will not boot. granted the mobo is more sophisticated and i have added more to the system. my sound card will not power up. i can connect the cpu and the system starts; but when i plug the gpu (2xpin PCIE) in to the psu then the system will not boot. maybe i am over thinking it or is simple enough to not consider? wht am i forgetting about? and do i have enough power (1000w) to supply all components?

Build to date:
CPU:
amd ryzen 5950x OCd@4.4Ghz
Motherboard: asus rog crosshair 8 formula x570
Memory: G.SKILL TridentZ RGB Series (4x16gb dimms) OCd 4400mhz
Storage: Mushkin Enhanced Helix-L M.2 2280 1TB
Video Card: SAPPHIRE NITRO+ AMD RADEON RX 6900 XT
Sound card: Creative Sound BlasterX AE-5 Plus SABRE32-class
Case: Fractal Design Meshify 2 XL Black ATX
Power Supply: CORSAIR RMx Series (2021) RM1000x CP-9020201-NA 1000 W ATX12V / EPS12V SLI Ready CrossFire Ready 80 PLUS GOLD Certified Full Modular Active Pfc power supply
Loop components: EKWB EK-Quantum Velocity CPU Water Block, EK-QUANTUM VECTOR N+ RX 6800XT/6900XT D-RGB water block and backplate, EKWB EK-RAM Monarch X4 Waterblock, Nickel (w/modules), EK quantum momentum VRM bridge, monoblock; EK-Quantum Kinetic TBE 200 D5 PWM D-RGB - Plex; EK-Quantum Surface P420M; 10/16mm soft tubing; mystic fog premix.

any help would be appreciated 😊 thanks!