Crysis Remastered audio all of a sudden just beeps - SOLVED!

Nov 18, 2021
3
2
10
Greetings - first post! I've been playing Crysis Remastered for a while (I never played the original) and it's been great. However, last week, all of a sudden the audio comes in the left channel as a beeping sound, and there's no dialog or anything else! I've restarted the game but the same issue. I had just started Awakening....... anyone have this issue? Thanks in advance
 

Brian Boru

Moderator
Welcome to the forum :)

First, the obvious: disconnect and reconnect all cables involved in your audio setup.

If you can, change your audio output—eg from headset to monitor or speakers—to see if problem persists. That will identify or rule out your output device as the problem.

Check for a new driver for your audio device(s)—eg audio card or built-in audio, which is usually Realtek. You can find all these in Device Manager.

If your graphics card also does audio—it very probably does—update its driver also.

In Device Manager, make sure only your preferred audio output device is enabled—there can be 4-6 different devices enabled, and maybe they're getting in each other's way.
 
  • Like
Reactions: Zloth
Nov 18, 2021
3
2
10
Hey Brian - thanks for the detailed troubleshooting tips! I went back and looked at my audio devices and sure enough, all were enabled. I only use the onboard Reaktek sound but the Nvidia HD audio and the Realtek digital outputs were all enabled as well. Once I disabled these two devices, the sound came back in Crysis and no beeping! Not sure how those became enabled (I did do a driver update recently) but turning them off put me back in the game. I'm calling this solved - thanks Brian and Colif!
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts