Solved Blurry graphics jedi fallen order

Apr 7, 2020
11
2
15
*am i the only one who feels the graphics are kind of blurry and not so sharp even on epic settings in jedi fallen order?
*i play on pc
*is there any solution for this?
 

Zoid

Community Contributor
Jan 13, 2020
515
641
1,270
Have you double checked to make sure you are running the game at your display's native resolution and that resolution scaling options in the game are turned off?
 

Frindis

Moderator
Jan 14, 2020
1,641
1,830
5,070
Not played the game myself, but it might help to turn off the depth of field/blur if you have not tried that yet. If that does not work, you could also try to change sg.TextureQuality=4 (from 3) in gameusersettings.ini.
 
  • Like
Reactions: Zoid and randyl
Jan 19, 2020
60
70
120
Not played the game myself, but it might help to turn off the depth of field/blur if you have not tried that yet. If that does not work, you could also try to change sg.TextureQuality=4 (from 3) in gameusersettings.ini.
Great points. Motion Blur and Depth of Field are two settings I nearly always disable when possible. In my opinion it is rare for a title to implement those well. God Rays is number 3 on the list of things I disable in settings.
 
  • Like
Reactions: Frindis
Mar 30, 2021
1
0
10
*am i the only one who feels the graphics are kind of blurry and not so sharp even on epic settings in jedi fallen order?
*i play on pc
*is there any solution for this?
Bro I was having the same problem for some time now. So I went to Video ---> changed Window mode from Borderless Fullscreen to Fullscreen only. Then I manually changed the Resolution to my Native display resolution. Worked like a charm. The game doesn't look like **** anymore yayyy :)
 

ASK THE COMMUNITY

TRENDING THREADS