Question Blue screen at each boot after successfuly upgrading computer

Not open for further replies.
Dec 29, 2020
Visit site
Hi everyone,
I have a problem with bluescreen at every boot

I changed my computer not long ago and just kept the hard drive, the power supply (coolermaster RS600 acab D3) and the graphic card (Nvidia Geforce GTX 770) because everything else was incompatible. After mounting everything, the PC was working fine.

I spent a few days solving software problems (w10 license).
After 3 days I decided to install the drivers of the motherboard's website (just in case) and I rebooted several times in the process, the PC worked fine.

The next day, I start up and after 2min the computer suddenly shuts down and restarts. But it boots on blue screens and reboots itself in a loop. The errors were different but after several reboot it always reboots on "kernel security check failure".

I tried to boot on a w10 live usb, I have the same error. I tried to reset the bios ,same thing. I tried to keep one or the other of the two ram modules, same. I reinstalled windows completely multiple times but also the same.

Also, the startup screen is a bit different. I have during 2 or 3 seconds a flashing underscore on a black background like ms-dos but without any text.
Meanwhile, there is no problem once back on the old pc.

So I imagine it must be a hardware problem.

Do you have any ideas how can I know which component is responsible to send it back ?
I think it could be cpu or motherboard as ram doesn't change anything but I don't see any way to test it.

My config :
Motherboard : msi x470 gaming plus max
CPU: AMD ryzen 7 3700x
Ram: PNY XLR8 8*2 GB 3200MHz Cl 16
Graphics card: Geforce GTX 770
Have a look at this page.

I tried to reset the bios
Do you mean update the BIOS? Ryzen 7 3rd gen needs a BIOS update from the bits I read.

kept the hard drive … and the graphic card (Nvidia Geforce GTX 770)
What's the hard drive, and how much free space is on it?
GTX 770 is fairly old relative to your CPU & RAM. If the HD is similarly old, maybe your system is too unbalanced for Windows liking.

My guess is it's a driver incompatibility, but lord knows for which device. If you're still in trouble, try updating as many as you can.
Not open for further replies.


Latest posts